АИС "Работа с покупателями"

ФункцияглВернутьЦену(Номенклатура,ТипЦены,ДатаЦены=0,ЦенаЦены=0,ЕдЦены=0,ВалЦены=0,НаценкаЦены=0,НайденнаяЦена=0,НеДобавИздержки=0)ЭкспортДалее ФункцияGlVozrOst(кд_ном)ЭкспортДалее ФункцияGlVozrCeni()ЭкспортДалее ФункцияGlVozrNom()ЭкспортДалее //############################################################################### //БлокдляработысинтернетмагазиномчерезWebслужбу //******************************************************************* //Функциявозвращаетпараметрпоимениизфайлаnastr.txtрабочегокаталога //Форматфайла: //строкиначинающиесяс#-коментарии //имяпараметразадаётсякак[имя],азначениележитнастрочкувнизу ФункцияПарамПоИмени(пар) ПеремномСтрок; Перемстр; Ткст=СоздатьОбъект("Текст"); Ткст.КодоваяСтраница(0); Ткст.Открыть(КаталогИБ()+"nastr.txt"); номСтрок=1; ПоканомСтрок<=Ткст.КоличествоСтрок()Цикл стр=Ткст.ПолучитьСтроку(номСтрок); //удаляемпробелывначалеиконцестроки СокрЛП(стр); ЕслистрДлина(стр)>0Тогда //Есликоментарий,топропускаем ЕслиЛев(стр,1)="#"Тогда номСтрок=номСтрок+1; Продолжить; КонецЕсли; //Есликакойтопараметр,тогда ЕслиЛев(стр,1)="["Тогда стр=лев(стр,стрДлина(стр)-1); стр=прав(стр,стрДлина(стр)-1); //Еслиэтотпараметр-искомый Еслистр=парТогда ВозвратСокрЛП(Ткст.ПолучитьСтроку(номСтрок+1)); КонецЕсли; КонецЕсли; КонецЕсли; номСтрок=номСтрок+1; КонецЦикла; Возврат"0";//Еслиничегоненашли-возвращаетноль КонецФункции //****************************************************************** //Функциявозвращаетколичествотоварапоегокоду,преднозначенадлявыводачерезWebслужбу ФункцияGlVozrOst(кд_ном)Экспорт ПеремОст; Ном=создатьОбъект("Справочник.Номенклатура"); Склд=СоздатьОбъект("Справочник.Склады"); Регр=СоздатьОбъект("Регистр.ОстаткиТМЦ"); Склд.НайтиПоКоду("00001"); Ном.НайтиПоКоду(кд_ном); Ост=0; Ост=Регр.СводныйОстаток(,ном.ТекущийЭлемент(),Склд.ТекущийЭлемент(),,"Количество"); ВозвратОст; КонецФункции //******************************************************************* //Функциявозвращаеттаблицузначений-номенклатурускодомиеёпараметры ФункцияGlVozrNom()Экспорт ПеремОст,ТабЗн; ПеремКатВыгр; Запрос=СоздатьОбъект("Запрос"); ТекстЗапроса= "//{{ЗАПРОС(Номенклатура) |Ном=Справочник.Номенклатура.ТекущийЭлемент; |ГруппировкаНом;"//}}ЗАПРОС ; ЕслиЗапрос.Выполнить(ТекстЗапроса)=0Тогда Предупреждение("Ошибкавзапросе"); КонецЕсли; КатВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Ном"); ДБФ=СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("EtoGruppa",1,1,0); ДБФ.ДобавитьПоле("KodNom",2,9,0); ДБФ.ДобавитьПоле("Otec",2,9,0); ДБФ.ДобавитьПоле("Strana",2,20,0); ДБФ.ДобавитьПоле("Naimenov",2,250,0); ДБФ.СоздатьФайл(КатВыгр+"nomen.dbf"); ДБФ.КодоваяСтраница(1); Запрос.ВНачалоВыборки(); ПокаЗапрос.Группировка(1)=1Цикл ДБФ.Добавить(); ДБФ.KodNom=Запрос.Ном.Код; ДБФ.Otec=Запрос.Ном.Родитель.Код; ДБФ.Strana=Запрос.Ном.СтранаПроисхождения.Наименование;; ДБФ.Naimenov=Запрос.Ном.Наименование; ДБФ.EtoGruppa=Запрос.ЭтоГруппа(1); ДБФ.Записать(); КонецЦикла; Возврат1; КонецФункции //******************************************************************* //Возвращаетценупоуказаннымпарметрам-используетсявзапросевнизу ФункцияВозрНомерПрайса(Кд)Экспорт ЕслиКд="00002"Тогда Возврат1; ИначеЕслиКд="00003"Тогда Возврат2; ИначеЕслиКд="00004"Тогда Возврат3; ИначеЕслиКд="00005"Тогда Возврат4; ИначеЕслиКд="00006"Тогда Возврат5; ИначеЕслиКд="00007"Тогда Возврат6; ИначеЕслиКд="00001"Тогда Возврат0; Иначе Возврат33;//Еслиошибка.0нельзя,т.к.вдругэтоунасболеенизкие КонецЕсли; КонецФункции //******************************************************************* //Функциявозвращаетценынаноменклатуруиномерпрайса ФункцияGlVozrCeni()Экспорт ПеремОст,ТабЗн; ПеремКатВыгр; ПеремизПроц; Запрос=СоздатьОбъект("Запрос"); ТекстЗапроса= "//{{ЗАПРОС(Цены) |Номенклатура=Справочник.Цены.Владелец; |ТипКод=Справочник.Цены.ТипЦен.Код; |Тип=Справочник.Цены.ТипЦен; |Цен=Справочник.Цены.ТекущийЭлемент; |ГруппировкаЦен; |"//}}ЗАПРОС ; ЕслиЗапрос.Выполнить(ТекстЗапроса)=0Тогда Предупреждение("Ошибкавзапросе"); КонецЕсли; КатВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Цен"); ДБФ=СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("Cena",1,8,2); ДБФ.ДобавитьПоле("Nomen",2,9,0); ДБФ.ДобавитьПоле("Prajs",1,2,0); ДБФ.СоздатьФайл(КатВыгр+"Ceni.dbf"); ДБФ.КодоваяСтраница(1); Запрос.ВНачалоВыборки(); ПокаЗапрос.Группировка(1)=1Цикл Если(Запрос.ТипКод<>"00010")Тогда ДБФ.Добавить(); глВернутьЦену(Запрос.Номенклатура,Запрос.Тип,,изПроц,,,,0); ДБФ.Cena=изПроц; ДБФ.Nomen=Запрос.Номенклатура.Код; ДБФ.Prajs=ВозрНомерПрайса(Запрос.ТипКод); ДБФ.Записать(); КонецЕсли; КонецЦикла; Возврат1; КонецФункции //******************************************************************* //Функциявозвращаетостаткиноменклатуры ФункцияGlVozrOstatki()Экспорт ПеремкатВыгр,дат; Перемск; ОСТ=СоздатьОбъект("XBase"); ОСТ.ДобавитьПоле("Kod",2,9,0); ОСТ.ДобавитьПоле("Ostatok",1,5,0); катВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Ост"); ОСТ.СоздатьФайл(катВыгр+"ost.dbf");

АИС Работа с покупателями

Реферат

Компьютеры, программирование

Другие рефераты по предмету

Компьютеры, программирование

Сдать работу со 100% гаранией
ажать на кнопку «Распечатать ценники», после чего на экране появится отчёт с ценниками, по номенклатуре, находящейся в правой части окна, готовый к печати. Данный отчёт показан на рисунке 20.

Рисунок 20 - ценники

 

Выберите в меню пункт «Файл», далее «Печать».

 

5.1.8 Загрузка накладных:

Для загрузки накладной в БД требуется:

  1. Установить flesh память в USB разъём
  2. Открыть из 1С обработку из корневой папки съемного диска «»
  3. После этого на экране появится окно обработки, показанное на рисунке 21.

Рисунок 21 окно подпрограммы «загрузка документов»

 

  1. Выберите каталог с файлами перегружаемых данных (имя каталога должно совпадать с номером накладной).
  2. Выберите склад и тип цен
  3. Нажмите кнопку «Загрузить»
  4. Дождитесь обработки выгрузки и распечатайте все полученные по окончании ценники.

 

5.2 Эксплуатация WEB портала

Настройку и доработку приложения должен производить лишь опытный разработчик с квалификацией по используемым технологиям.

На начальном этапе допускается непосредственное изменение записей таблиц посредством программы SQL Server.

Требования к компьютеру WEB пользователя таковы:

  1. Internet Explorer 6 x
  2. Разрешение экрана выше, либо равное 1024x768
  3. Разрешение всплывающих окон (для Windows XP SP2)
  4. Разрешение использования Java Script

Работа основана на интуитивно понятных принципах, уже устоявшихся в современном сайтостроении.

 

 

ЗАКЛЮЧЕНИЕ

 

Полученная АИС «Работа с покупателями» представляет собой законченный продукт, полностью отвечающий предъявленным требованиям.

В комплекс входят программные средства:

  1. для поддержания актуального состояния распределённой базы данных
  2. автоматизирующие работу кассира
  3. копирования данных с сервера 1С и с удалённых точек на WEB сервер (SQL Server 2000).
  4. Законченный Интернет портал, отвечающий поставленным требованиям

Созданная распределённая база данных успешно функционирует на предприятии более месяца. Интернет портал будет введён в коммерческую эксплуатацию с середины июля 2005 года.

 

СПИСОК ИСПОЛЬЗОВАННЫХ ИСТОЧНИКОВ

 

 

  1. Прилагаемая к системе «1С предприятие» документация и встроенная справка (синтаксис помощник).
  2. «1С:Торговля и Склад в вопросах и ответах: Практическое пособие». Богачева Т. Г. М.: ООО «1С-Паблишинг», 2003 г. -273 с.
  3. «Конфигурирование и администрирование 1С: Предприятия». Тимофеев Г.С., Шумейко Д.А. Ростов н/Д: Феникс, 2003 г 320 с.
  4. «1С:Предпирятие: программирование для всех». Бартеньев О.В. М.: Диалог-МИФИ, 2004. 464 с.
  5. «1С:Предприятие. Эффективное программирование». Усиков Т.Н. М.:Новое знание, 2004 г. 464с.
  6. Форум «Территория “1С”»: http://www.kuban.ru/cgi-bin/forum/forum9.cgi
  7. Клуб профессионалов 1С: http://1c.proclub.ru/
  8. «Windows Server 2003. Для профессионалов». Вишневский Алексей Викторович. СПб.: Питер, 2004. 767 с.
  9. «Как программировать для Internet и WWW». Дейтел Х. М., Дейтел П. Дж., Нието Т. Р.. Пер. с англ. М.: ЗАО «Издательство БИНОМ», 2002 г. 1184 с.
  10. «JavaScript 1.5: Учебный курс». Кингсли-Хью Э., Кингсли-Хью К.: Питер, 2002 г. 272 с.
  11. «JavaScript и DHTML. Сборник рецептов. Для профессионалов». Гудман Д. СПб.: Питер, 2004 г. 523 с.
  12. «Основы ASP.NET с примерами на C#». Оньон Ф. Пер. с англ. М.: Издательский дом «Вильямс», 2003 г. 304 с.
  13. ASP .Net Mania все про ASP.NET и .NET Framework: http://aspnetmania.com/

 

  1. «Использование C#. Специальное издание». Специалисты NIIT. Пер.с англ М.: Издательский дом «Вильямс», 2002 г. 528 с.
  2. «Самоучитель Visual Studio .NET 2003». Гарнаев А.Ю. - СПб.: БХВ - Петербург, 2003.- 688 с.
  3. «C# и платформа .NET. Библиотека программиста». Троелсен. Э. СПб.: Питер, 2005. 796 с.
  4. «Программирование web-сервисов для .NET. Библиотека программиста». Феррара Ф., Мак-Дональд М. Киев: BHV; СПб.: Питер, 2003. 430 с.
  5. MSDN Library for Visual Studio 2005 Beta
  6. http://rsdn.ru/
  7. http://www.gotdotnet.ru/
  8. «Microsoft SQL Server 7 для профессионалов». Мамаев Е., Вишневский А. СПб: Издательство «Питер», 2000 г. 896 с.
  9. «Visual Studio .NET: разработка приложений баз данных». Постолит А. В. СПб.: БХВ-Петербург, 2003 г. 544 с.
  10. «ADO.NET Сборник рецептов. Для профессионалов.». Гамильтон Б.- СПб.: Питер, 2005 576 с.
  11. http://sql.ru/

 

ПРИЛОЖЕНИЕ А

Концептуальная модель переноса данных.

ПРИЛОЖЕНИЕ Б

Код Web службы (Файл «Service.asmx»)

// Данная служба - возвращает остаток по посланному коду

 

using System.Web;

using System;

using System.Reflection;

using System.Web.Services;

using System.Web.Services.Protocols;

using System.Data;

using System.Data.OleDb;

 

[WebServiceBinding(ConformanceClaims=WsiClaims.BP10,EmitConformanceClaims = true)]

public class Service : System.Web.Services.WebService {

private

// Параметры для подключения к 1С

Type _1C = null; // ассоциация с программой

object tor = null; // COM объект

object rmtrade = null;

object[] args = null; // аргументы для функции

object Order = null;

//***************************************************************************

// Подключение к 1С. Возвращает true в случае удачи и false - неудачи

bool podkluchenie(){

_1C = Type.GetTypeFromProgID("V77s.Application");

try{

tor = Activator.CreateInstance(_1C);

rmtrade = _1C.InvokeMember("RMTrade", BindingFlags.GetProperty, null, tor, null);

// Задаём парметры подключения, чтобы вход происходил автоматически

args = new object[] { rmtrade, "/DC:\\ttt\\ /NFOKS /P676676 ", "NO_SPLASH_SHOW" };

//Запуск 1С

_1C.InvokeMember("Initialize", BindingFlags.InvokeMethod, null, tor, args);

return true;

}

catch{

// Нет доступа к COM объекту

//return "Ошибка - проверь безопастность OLE";

//Скорее всего в Windows заданы права доступа к COM объектам только локальным

//пользователям. Лечится через "Служба компонентов"

return false;

}

}

//******************************************************************************

// Выполняет процедуру с заданным именем и с заданными параметрами

// Через неё обращаться к функциям, которые возвращают одну переменную

object Procedura1C_par(string Imja, string Param){

args = new object[] { Param };

return _1C.InvokeMember(Imja, BindingFlags.InvokeMethod, null, tor, args);

}

//******************************************************************************

// Выполняет процедуру с заданным именем и с заданными параметрами

// Через неё обращаться к функциям, которые возвращают ТЗ

object Procedura1C_tz(string Imja, string Param){

args = new object[] {};

//*return_1C.InvokeMember(Imja, BindingFlags.GetField | BindingFlags.InvokeMethod | BindingFlags.Default, null, tor, null);

return _1C.InvokeMember(Imja, BindingFlags.InvokeMethod | BindingFlags.OptionalParamBinding, null, tor, args);

}

//******************************************************************************

// Обращается к процедуре 1С и возвращает таблицу с результатами

// Через неё обращение к процедурам 1С, которые пишут файлы dbf

// Параметры:

// ImjaProc - имя вызываемой процедуры

// ImjaKat - каталог, из которого будут загружены таблицы

// ImjaTabl - имя таблицы

 

DataTable Vigr(string ImjaProc, string ImjaKat, string ImjaTabl)

{

// object ost;

int i;

string rez;

DataSet dt = new DataSet();

DataTable ddt = new DataTable();

if (podkluchenie())

{// Если удалось подключиться

try

{

rez = Procedura1C_tz(ImjaProc, "").ToString();

// Теперь у нас всё как надо - выгрузилась БД в файл.

// Подключаемся к ней через ADO.NET

string konekt = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source="+ImjaKat+";Extended Properties=dB

Похожие работы

<< < 4 5 6 7 8 9 10 > >>