АИС "Работа с покупателями"

ФункцияглВернутьЦену(Номенклатура,ТипЦены,ДатаЦены=0,ЦенаЦены=0,ЕдЦены=0,ВалЦены=0,НаценкаЦены=0,НайденнаяЦена=0,НеДобавИздержки=0)ЭкспортДалее ФункцияGlVozrOst(кд_ном)ЭкспортДалее ФункцияGlVozrCeni()ЭкспортДалее ФункцияGlVozrNom()ЭкспортДалее //############################################################################### //БлокдляработысинтернетмагазиномчерезWebслужбу //******************************************************************* //Функциявозвращаетпараметрпоимениизфайлаnastr.txtрабочегокаталога //Форматфайла: //строкиначинающиесяс#-коментарии //имяпараметразадаётсякак[имя],азначениележитнастрочкувнизу ФункцияПарамПоИмени(пар) ПеремномСтрок; Перемстр; Ткст=СоздатьОбъект("Текст"); Ткст.КодоваяСтраница(0); Ткст.Открыть(КаталогИБ()+"nastr.txt"); номСтрок=1; ПоканомСтрок<=Ткст.КоличествоСтрок()Цикл стр=Ткст.ПолучитьСтроку(номСтрок); //удаляемпробелывначалеиконцестроки СокрЛП(стр); ЕслистрДлина(стр)>0Тогда //Есликоментарий,топропускаем ЕслиЛев(стр,1)="#"Тогда номСтрок=номСтрок+1; Продолжить; КонецЕсли; //Есликакойтопараметр,тогда ЕслиЛев(стр,1)="["Тогда стр=лев(стр,стрДлина(стр)-1); стр=прав(стр,стрДлина(стр)-1); //Еслиэтотпараметр-искомый Еслистр=парТогда ВозвратСокрЛП(Ткст.ПолучитьСтроку(номСтрок+1)); КонецЕсли; КонецЕсли; КонецЕсли; номСтрок=номСтрок+1; КонецЦикла; Возврат"0";//Еслиничегоненашли-возвращаетноль КонецФункции //****************************************************************** //Функциявозвращаетколичествотоварапоегокоду,преднозначенадлявыводачерезWebслужбу ФункцияGlVozrOst(кд_ном)Экспорт ПеремОст; Ном=создатьОбъект("Справочник.Номенклатура"); Склд=СоздатьОбъект("Справочник.Склады"); Регр=СоздатьОбъект("Регистр.ОстаткиТМЦ"); Склд.НайтиПоКоду("00001"); Ном.НайтиПоКоду(кд_ном); Ост=0; Ост=Регр.СводныйОстаток(,ном.ТекущийЭлемент(),Склд.ТекущийЭлемент(),,"Количество"); ВозвратОст; КонецФункции //******************************************************************* //Функциявозвращаеттаблицузначений-номенклатурускодомиеёпараметры ФункцияGlVozrNom()Экспорт ПеремОст,ТабЗн; ПеремКатВыгр; Запрос=СоздатьОбъект("Запрос"); ТекстЗапроса= "//{{ЗАПРОС(Номенклатура) |Ном=Справочник.Номенклатура.ТекущийЭлемент; |ГруппировкаНом;"//}}ЗАПРОС ; ЕслиЗапрос.Выполнить(ТекстЗапроса)=0Тогда Предупреждение("Ошибкавзапросе"); КонецЕсли; КатВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Ном"); ДБФ=СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("EtoGruppa",1,1,0); ДБФ.ДобавитьПоле("KodNom",2,9,0); ДБФ.ДобавитьПоле("Otec",2,9,0); ДБФ.ДобавитьПоле("Strana",2,20,0); ДБФ.ДобавитьПоле("Naimenov",2,250,0); ДБФ.СоздатьФайл(КатВыгр+"nomen.dbf"); ДБФ.КодоваяСтраница(1); Запрос.ВНачалоВыборки(); ПокаЗапрос.Группировка(1)=1Цикл ДБФ.Добавить(); ДБФ.KodNom=Запрос.Ном.Код; ДБФ.Otec=Запрос.Ном.Родитель.Код; ДБФ.Strana=Запрос.Ном.СтранаПроисхождения.Наименование;; ДБФ.Naimenov=Запрос.Ном.Наименование; ДБФ.EtoGruppa=Запрос.ЭтоГруппа(1); ДБФ.Записать(); КонецЦикла; Возврат1; КонецФункции //******************************************************************* //Возвращаетценупоуказаннымпарметрам-используетсявзапросевнизу ФункцияВозрНомерПрайса(Кд)Экспорт ЕслиКд="00002"Тогда Возврат1; ИначеЕслиКд="00003"Тогда Возврат2; ИначеЕслиКд="00004"Тогда Возврат3; ИначеЕслиКд="00005"Тогда Возврат4; ИначеЕслиКд="00006"Тогда Возврат5; ИначеЕслиКд="00007"Тогда Возврат6; ИначеЕслиКд="00001"Тогда Возврат0; Иначе Возврат33;//Еслиошибка.0нельзя,т.к.вдругэтоунасболеенизкие КонецЕсли; КонецФункции //******************************************************************* //Функциявозвращаетценынаноменклатуруиномерпрайса ФункцияGlVozrCeni()Экспорт ПеремОст,ТабЗн; ПеремКатВыгр; ПеремизПроц; Запрос=СоздатьОбъект("Запрос"); ТекстЗапроса= "//{{ЗАПРОС(Цены) |Номенклатура=Справочник.Цены.Владелец; |ТипКод=Справочник.Цены.ТипЦен.Код; |Тип=Справочник.Цены.ТипЦен; |Цен=Справочник.Цены.ТекущийЭлемент; |ГруппировкаЦен; |"//}}ЗАПРОС ; ЕслиЗапрос.Выполнить(ТекстЗапроса)=0Тогда Предупреждение("Ошибкавзапросе"); КонецЕсли; КатВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Цен"); ДБФ=СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("Cena",1,8,2); ДБФ.ДобавитьПоле("Nomen",2,9,0); ДБФ.ДобавитьПоле("Prajs",1,2,0); ДБФ.СоздатьФайл(КатВыгр+"Ceni.dbf"); ДБФ.КодоваяСтраница(1); Запрос.ВНачалоВыборки(); ПокаЗапрос.Группировка(1)=1Цикл Если(Запрос.ТипКод<>"00010")Тогда ДБФ.Добавить(); глВернутьЦену(Запрос.Номенклатура,Запрос.Тип,,изПроц,,,,0); ДБФ.Cena=изПроц; ДБФ.Nomen=Запрос.Номенклатура.Код; ДБФ.Prajs=ВозрНомерПрайса(Запрос.ТипКод); ДБФ.Записать(); КонецЕсли; КонецЦикла; Возврат1; КонецФункции //******************************************************************* //Функциявозвращаетостаткиноменклатуры ФункцияGlVozrOstatki()Экспорт ПеремкатВыгр,дат; Перемск; ОСТ=СоздатьОбъект("XBase"); ОСТ.ДобавитьПоле("Kod",2,9,0); ОСТ.ДобавитьПоле("Ostatok",1,5,0); катВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Ост"); ОСТ.СоздатьФайл(катВыгр+"ost.dbf");

АИС Работа с покупателями

Реферат

Компьютеры, программирование

Другие рефераты по предмету

Компьютеры, программирование

Сдать работу со 100% гаранией
Отправка электронной почты

Для отправки сообщений на электронную почту используется учётная запись внутреннего почтового сервера «InternetMagazin@mirposudy.com». В Visual Studio 2005 произошли изменения и в новом продукте используется иная схема отправки сообщений, нежели чем в Visual Studio 2003. Страницы, с которых отправляются электронные письма показаны на рисунке 11.

Рисунок 11 Форма отправки тестового сообщения

 

4.3.6 Полномочия пользователей

В соответствии с требованиями к программному продукту пользователи делятся на две группы не авторизированные и авторизированные.

Не авторизированные пользователи, они же «гости» имеют права на просмотр есть ли товар на розничной точке (без указания конкретного количества) и видят его цену по 1 прайсу (чем выше номер прайса, тем дешевле стоит товар). Делать заказ пользователи данного типа не могут.

Авторизированные пользователи это покупатели - оптовики, которым имя пользователя и пароль выдаётся менеджерами. Покупать товар они могут по номеру прайса, заданного менеджером. Номер прайса зависит от двух критериев: объемы предыдущих закупок и частота покупок. Данная группа пользователей может оформлять заказы на товар.

Все остальные возможности у обеих групп одинаковы.

Информационно функциональная схема «работа авторизированного пользователя в системе» показана на рисунке 12.

Рисунок 12 - работа авторизированного пользователя в системе

 

«Отчёт по товару» для выгрузки в формате Excel абсолютно идентичен данным, выводимым в DataView.

 

2.4.7 Проблемы и их решение

Проблемы и их решение:

  1. Невозможность взаимодействия JavaScript с кодом на C#. Решение: использовать параметры, передаваемые в строке запроса,
  2. Отсутствие документации на русском языке. Решение: изучение иностранного языка,
  3. Отсутствие средств отладки JavaScript. Решение: использование окон сообщений «ShowAlert» для отображения значений переменных. Мне это очень помогло при поиске зацикливания в одной из процедур.

5 ТЕХНОЛОГИЯ ЭКСПЛУАТАЦИИ ПРИЛОЖЕНИЯ

 

5.1 Инструкция оператора системы 1С на удалённом магазине

Содержание инструкции:

  1. Общие сведения,
  2. Порядок работы,
  3. Продажа (реализация),
  4. Возврат продажи,
  5. Использование меню фискального регистратора(ФР),
  6. Акт сверки,
  7. Печать ценников по подбору,
  8. Загрузка накладных.

 

5.1.1 Общие сведения

База данных ведётся пользователем с правами Кассира. Доступны такие действия, как:

  1. отпуск товара с распечаткой чека,
  2. оформление возврата с печатью чека на возврат продажи,
  3. загрузка накладных, полученных с основной базы, с добавлением новой номенклатуры и изменением цен в справочнике цен,
  4. формирование акта сверки.

Используется фискальный регистратор «Штрих ФР-К»

 

5.1.2 Порядок работы:

В течении дня оформляются продажи в текущем времени. Если нужно обменять товар, то оформляются последовательно возврат и продажа. В конце дня закрывается смена делается полный отчёт с гашением на ФР и печатается акт сверки по указанному ниже алгоритму. В итоге получаем итоги, которые должны совпадать наличность, итог по акту сверки из 1С и итог по итоговой ленте ФР.

 

5.1.3 Продажа (Реализация):

Для оформления продажи нужно:

  1. щёлкнуть по пиктограмме «реализация» на панели управления. После этого откроется окно, поля которого должны уже быть заполнены по умолчанию (менять ничего не нужно). Окно показано на рисунке 13.

Рисунок 13 Окно документа «Реализация»

 

  1. Прейти на закладку «Табличная часть». Развернуть окно, два раза щёлкнув на его заголовке или на пиктограмме «развернуть». После чего нажать на кнопку «Цены…» и в появившемся окне выбрать тип цен «Розничная» и установить галку на «Включён в сумму». Результат показан на рисунке 14.

Рисунок 14 - Настройка документа «Реализация»

 

Надо нажать кнопку «ОК» и подобрать товар, используя кнопку «Подбор».

Получаем окно, показанное на рисунке 15.

Рисунок 15 - подбор номенклатуры

В поле «Запрашивать» для удобства работы должно быть выставлено «Количество». Для ускорения поиска желательно пользоваться кнопкой «Поиск», учитывая, что код состоит из 9 символов, а в начале идут нули.

После подбора выбранный товар появляется в нижней таблице. Нажатием кнопки «Ок» он переносится в тело документа.

  1. После подбора внизу окна высвечивается сумма, которую должен уплатить покупатель. В поле «Сумма от покупателя» надо обязательно ввести сумму, которую внёс покупатель. Потому что при печати чека будет выведена сумма сдачи.

После этого если вы хотите сделать реализацию с печатью чека, то нажимайте кнопку «Печать чека», а если без, то просто «Провести». После этого документ будет недоступен для редактирования. Появится информационное окно, в котором будет отображено удачна ли попытка проведения. Если удачна, то закройте его. Если неудачна попытайтесь устранить причину.

 

5.1.4 Возврат продажи

Для оформления возврата продажи:

  1. Щёлкните мышкой по иконке с красным крестиком в панели инструментов 1С.
  2. Открывается окно. Аналогично предыдущему документу поля на вкладке «Шапка» должны быть установлены должным образом по умолчанию. Жмите на кнопку «Основание», выбирайте документы «Реализация» и ищите документ, по которому был отпущен товар (номер документа печатается на чеке). На вопрос заполнять ли документ по документу основанию отвечаете утвердительно «да».
  3. Переходите к вкладке «ТМЦ и услуги (по отпускным ценам)».

В таблице отображаются все товары, которые прошли по документу основанию. Нам нежно оставить лишь те, которые действительно возвращают. Цены должны стоять те, по которым отпускали товар. Удалить не нужные позиции можно кликая на нужной правой кнопкой мыши и выбирая пункт «Удалить строку», либо активируя строчку и нажимая на клавиатуре клавишу «Delete»(что будет быстрее).

Форма удаления показана на рисунке 16.

Рисунок 16 - Удаление позиций из документа «Возврат продажи»

 

  1. Нажать кнопку «Провести». Если ФР не подключён, то вывалится сообщение о невозможности распечатать чек, но товар будет возвращён на склад.
  2. Закройте окно документа (если оно не закрылось автоматически)

 

5.1.5 Использование меню фискального регистратора (ФР):

В меню программы 1С имеется меню «ФР»:

Элементы меню выполняют следующие функции:

  1. «Суточный отчёт с гашением» - закрывает смену, выводит полный фискальный отчёт по продажам с момента прошлого закрытия смены.
  2. «Суточный отчет без гашения» - выводит отчет по продажам с начала смены.
  3. «Отменить чек» - отмена чека системным администратором. Если произошла отмена чека, то надо будет перепечатать чек. Чек отменяется, если он не распечатался и фискальник «завис». Это может быть если несвоевременно поменяли бумагу (кончилась при печати), либо зажевало бумагу, либо сбилось питание.
  4. «Проверка связи» - выдаст ошибку, если нет связи с фискальным регистратором.

 

5.1.6 Акт сверки:

Данная обработка показывает что прошло по программе за указанный период.

Обработка вызывается из «Файл - > Открыть». Далее нужно выбрать каталог «С:\Base\Внешние обработки мира посуды» и дважды щёлкнуть по файлу «акт сверки для магазина.ert». После чего откроется обработка, внешний вид которой показан на рисунке 17.

 

Рисунок 17 - Акт сверки

 

Нужно указать период, покупателя и магазин. Склад можно не указывать (тогда будет по всем складам). Также можно не указывать покупателя, тогда соответственно будет выдан отчёт по всем покупателям. Хочу обратить внимания на кнопочки, выделенные на рисунке. Они позволяют сохранять и загружать параметры по умолчанию. То есть один раз выбрав нужные вам параметры вы сохраняете настройку, а при следующей загрузке параметры будут выставлены так, как вы их выставляли в прошлый раз. Не надо будет каждый раз делать одно и то же.

После задания параметров следует нажать кнопку «сформировать». Будет получен отчёт, показанный на рисунке 18.

Рисунок 18 - отчёт по акту сверки

 

В случае расхождений между фискальным отчётом, актом сверки и наличностью ищите причины ошибки.

 

5.1.7 Печать ценников по подбору:

Данная обработка позволяет напечатать ценники (по 16 ценников на страницу) на выбранный товар.

Внешний вид обработки показан на рисунке 19:

Рисунок 19 - «Печать ценников по подбору»

Как видно из рисунка 19. Требуется отобрать в левой части экрана нужную позицию, дважды щёлкнуть по ней, или нажать на кнопку « > », после чего она попадёт в правую часть экрана.

Для ускорения подбора можно пользоваться поиском по коду, либо менять порядок сортировки и отображения номенклатуры в левой части окна.

После выбора всех позиций, по которым требуется распечатать ценники нужно выбрать тип цен и н

Похожие работы

<< < 3 4 5 6 7 8 9 10 > >>