АИС "Работа с покупателями"

ФункцияглВернутьЦену(Номенклатура,ТипЦены,ДатаЦены=0,ЦенаЦены=0,ЕдЦены=0,ВалЦены=0,НаценкаЦены=0,НайденнаяЦена=0,НеДобавИздержки=0)ЭкспортДалее ФункцияGlVozrOst(кд_ном)ЭкспортДалее ФункцияGlVozrCeni()ЭкспортДалее ФункцияGlVozrNom()ЭкспортДалее //############################################################################### //БлокдляработысинтернетмагазиномчерезWebслужбу //******************************************************************* //Функциявозвращаетпараметрпоимениизфайлаnastr.txtрабочегокаталога //Форматфайла: //строкиначинающиесяс#-коментарии //имяпараметразадаётсякак[имя],азначениележитнастрочкувнизу ФункцияПарамПоИмени(пар) ПеремномСтрок; Перемстр; Ткст=СоздатьОбъект("Текст"); Ткст.КодоваяСтраница(0); Ткст.Открыть(КаталогИБ()+"nastr.txt"); номСтрок=1; ПоканомСтрок<=Ткст.КоличествоСтрок()Цикл стр=Ткст.ПолучитьСтроку(номСтрок); //удаляемпробелывначалеиконцестроки СокрЛП(стр); ЕслистрДлина(стр)>0Тогда //Есликоментарий,топропускаем ЕслиЛев(стр,1)="#"Тогда номСтрок=номСтрок+1; Продолжить; КонецЕсли; //Есликакойтопараметр,тогда ЕслиЛев(стр,1)="["Тогда стр=лев(стр,стрДлина(стр)-1); стр=прав(стр,стрДлина(стр)-1); //Еслиэтотпараметр-искомый Еслистр=парТогда ВозвратСокрЛП(Ткст.ПолучитьСтроку(номСтрок+1)); КонецЕсли; КонецЕсли; КонецЕсли; номСтрок=номСтрок+1; КонецЦикла; Возврат"0";//Еслиничегоненашли-возвращаетноль КонецФункции //****************************************************************** //Функциявозвращаетколичествотоварапоегокоду,преднозначенадлявыводачерезWebслужбу ФункцияGlVozrOst(кд_ном)Экспорт ПеремОст; Ном=создатьОбъект("Справочник.Номенклатура"); Склд=СоздатьОбъект("Справочник.Склады"); Регр=СоздатьОбъект("Регистр.ОстаткиТМЦ"); Склд.НайтиПоКоду("00001"); Ном.НайтиПоКоду(кд_ном); Ост=0; Ост=Регр.СводныйОстаток(,ном.ТекущийЭлемент(),Склд.ТекущийЭлемент(),,"Количество"); ВозвратОст; КонецФункции //******************************************************************* //Функциявозвращаеттаблицузначений-номенклатурускодомиеёпараметры ФункцияGlVozrNom()Экспорт ПеремОст,ТабЗн; ПеремКатВыгр; Запрос=СоздатьОбъект("Запрос"); ТекстЗапроса= "//{{ЗАПРОС(Номенклатура) |Ном=Справочник.Номенклатура.ТекущийЭлемент; |ГруппировкаНом;"//}}ЗАПРОС ; ЕслиЗапрос.Выполнить(ТекстЗапроса)=0Тогда Предупреждение("Ошибкавзапросе"); КонецЕсли; КатВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Ном"); ДБФ=СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("EtoGruppa",1,1,0); ДБФ.ДобавитьПоле("KodNom",2,9,0); ДБФ.ДобавитьПоле("Otec",2,9,0); ДБФ.ДобавитьПоле("Strana",2,20,0); ДБФ.ДобавитьПоле("Naimenov",2,250,0); ДБФ.СоздатьФайл(КатВыгр+"nomen.dbf"); ДБФ.КодоваяСтраница(1); Запрос.ВНачалоВыборки(); ПокаЗапрос.Группировка(1)=1Цикл ДБФ.Добавить(); ДБФ.KodNom=Запрос.Ном.Код; ДБФ.Otec=Запрос.Ном.Родитель.Код; ДБФ.Strana=Запрос.Ном.СтранаПроисхождения.Наименование;; ДБФ.Naimenov=Запрос.Ном.Наименование; ДБФ.EtoGruppa=Запрос.ЭтоГруппа(1); ДБФ.Записать(); КонецЦикла; Возврат1; КонецФункции //******************************************************************* //Возвращаетценупоуказаннымпарметрам-используетсявзапросевнизу ФункцияВозрНомерПрайса(Кд)Экспорт ЕслиКд="00002"Тогда Возврат1; ИначеЕслиКд="00003"Тогда Возврат2; ИначеЕслиКд="00004"Тогда Возврат3; ИначеЕслиКд="00005"Тогда Возврат4; ИначеЕслиКд="00006"Тогда Возврат5; ИначеЕслиКд="00007"Тогда Возврат6; ИначеЕслиКд="00001"Тогда Возврат0; Иначе Возврат33;//Еслиошибка.0нельзя,т.к.вдругэтоунасболеенизкие КонецЕсли; КонецФункции //******************************************************************* //Функциявозвращаетценынаноменклатуруиномерпрайса ФункцияGlVozrCeni()Экспорт ПеремОст,ТабЗн; ПеремКатВыгр; ПеремизПроц; Запрос=СоздатьОбъект("Запрос"); ТекстЗапроса= "//{{ЗАПРОС(Цены) |Номенклатура=Справочник.Цены.Владелец; |ТипКод=Справочник.Цены.ТипЦен.Код; |Тип=Справочник.Цены.ТипЦен; |Цен=Справочник.Цены.ТекущийЭлемент; |ГруппировкаЦен; |"//}}ЗАПРОС ; ЕслиЗапрос.Выполнить(ТекстЗапроса)=0Тогда Предупреждение("Ошибкавзапросе"); КонецЕсли; КатВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Цен"); ДБФ=СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("Cena",1,8,2); ДБФ.ДобавитьПоле("Nomen",2,9,0); ДБФ.ДобавитьПоле("Prajs",1,2,0); ДБФ.СоздатьФайл(КатВыгр+"Ceni.dbf"); ДБФ.КодоваяСтраница(1); Запрос.ВНачалоВыборки(); ПокаЗапрос.Группировка(1)=1Цикл Если(Запрос.ТипКод<>"00010")Тогда ДБФ.Добавить(); глВернутьЦену(Запрос.Номенклатура,Запрос.Тип,,изПроц,,,,0); ДБФ.Cena=изПроц; ДБФ.Nomen=Запрос.Номенклатура.Код; ДБФ.Prajs=ВозрНомерПрайса(Запрос.ТипКод); ДБФ.Записать(); КонецЕсли; КонецЦикла; Возврат1; КонецФункции //******************************************************************* //Функциявозвращаетостаткиноменклатуры ФункцияGlVozrOstatki()Экспорт ПеремкатВыгр,дат; Перемск; ОСТ=СоздатьОбъект("XBase"); ОСТ.ДобавитьПоле("Kod",2,9,0); ОСТ.ДобавитьПоле("Ostatok",1,5,0); катВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Ост"); ОСТ.СоздатьФайл(катВыгр+"ost.dbf");

АИС Работа с покупателями

Реферат

Компьютеры, программирование

Другие рефераты по предмету

Компьютеры, программирование

Сдать работу со 100% гаранией
вать отчёт-прайс в 1С, экспортировать в таблицу MS Excel и отправить покупателю по электронной почте. Политикой что кому показывать руководит один человек - начальник предприятия.

Весь этот процесс требовалось автоматизировать, разгрузив персонал от рутины, сделать покупку для покупателя максимально удобной и тем самым выделиться среди конкурентов (а конкуренция в этой области очень жесткая). Кроме того фирма относительно молодая, сеть розничных магазинов растёт (за полгода с 2 до 4), штат работников растёт, увеличивается количество компьютеров, оборот продаж.

 

1.3 Структура компьютерной сети предприятия

Немаловажную роль играет структура компьютерной сети предприятии. От её топологии зависит вся дальнейшая разработка программного комплекса. Протокол взаимодействия локальной сети: TCP-IP.

Схема локальной сети показана на рисунке 1:

Рисунок 1 Схема локальной сети предприятия

 

1.4 Выбор программных средств и технологий взаимодействия

Благодаря развитому на сегодняшний день в России компьютерному пиратству мы пока что имеем возможность свободно выбирать платформу и среду программирования, не смотря на финансовую составляющую покупки данных программных продуктов.

Все используемые программные средства более подробно будут рассмотрены далее. Сейчас я хочу описать почему же я остановился именно на них. Ведь на прилавках наших магазинов есть из чего выбирать.

 

1.4.1 Выбор СУБД для автоматизации хозяйственно-складской деятельности и построения распределённой БД

«1С Предприятие» 7.7 выбрано программой для построения складского учёта, так как на сегодняшний день у фирмы 1С в этой области практически нет конкурентов. 1С программа для ОС Windows. Все компьютеры предприятия работают на платформе Windows (XP Professional или Server 2003). Используется система 7.7, а не 8 так как учёт был поставлен до появления на широком рынке версии 8, которая до сих пор не получила широкого распространения (что не исключает, что за ней будущее). Система обладает нужной гибкостью, масштабируемостью. Синтаксис встроенного языка не представляет сложности и для человека, не имеющего компьютерного образования. Производители заявляют, что система поддерживает логику объектно ориентированного программирования. Но это всё же не так. Программирование процедурное. Некоторые средства массовой информации причисляют язык 1С к языку 4 уровня, с чем я конечно же тоже не соглашусь. Не хватает гибкости. Основной вариант, который можно рассматривать в качестве альтернативы 1С это создание самостоятельного продукта. Данный подход требует наличие высококвалифицированного персонала. Для процесса разработки, внедрения и модернизации потребуется больше времени. Но эффективность его использования на мой взгляд была бы выше, так как в системе не было бы ничего лишнего. Выбирать мне особо не приходилось, так как использование 1С началось до моего появления на фирме. Хочется отметить, что конфигурация дорабатывается не только мной, но и информационным отделом фирмы «Столица», с которыми у нас заключено деловое партнёрство. Что тоже повлияло на выбор.

Для создания распределённой БД также было решено использовать 1С, с нештатными средствами.

 

1.4.2 Выбор среды разработки

Данные с 1С надо получать, обрабатывать и предавать по локальной сети на WEB сервер. Кроме того, на Web сервере должен функционировать интернет сайт. Я решил использовать продукты компании Microsoft, которые лучше всего адаптированы под операционную систему MS Windows, быстры и надёжны.

На сегодняшний день серьёзную конкуренцию MS Visual Studio составляет компания Borland со своими продуктами Delphi и Builder. В плане простоты изучения данные средства разработки может быть и проще, не зря ведь в институтах и школах именно на них идёт обучение студентов и школьников. Но в плане ясности, отказоустойчивости, широте охвата областей программирования и документированности(MSDN) MS Visual Studio вне конкуренции. Кроме того я могу в одной графической оболочке разрабатывать две разнородные компоненты своей системы Web Service и Web Application.

В моём распоряжении оказалась Beta версия Visual Studio 2005, которую, я и решил использовать. Опыта программирования в данной среде у меня практически не было. Русскоязычных ресурсов по версии 2005 очень мало, в релизе возможны существенные изменения вплоть до того, что уже написанные приложения в beta версии перестанут функционировать. Но есть и преимущества. На 9 семестре в рамках дисциплины я писал лабораторную работу с использованием Visual Studio 2003 и ASP.NET. В новой версии (ASP 2.0) появились новые компоненты, были доработаны старые. Приятно удивил меня GridView своими возможностями. Считаю выбор оправданным. Никаких нареканий к стабильности работы, скорости работы и других характеристик полученных программных продуктов не имею.

 

1.4.3 Передача данных через локальную сеть

Было решено использовать связь «Web Служба» --> «ASP.NET приложение». Данная связка позволяет установить приложение на сервере с программой 1С, которое будет из вне доступно по протоколу HTTP, передавая данные по 80 порту в XML формате. Данная технология позволяет скрыть от конечного пользователя всю сложность преобразования данных из одного вида в другой и обратно. В моём случае используется относительно небольшой объём кода. Для доступа к данным используется технология ADO.NET.

 

1.4.4 Выбор языка программирования

MS Visual Studio позволяет вести разработку на одном из языков программирования: C#, C++, Java, Basic. Я везде использовал C#. C# перенял лучшее от Java и C++, автоматизировал работу с памятью, которую компилятор теперь берёт на себя. Синтаксис практически не отличается от C++ и непосредственно написание программного кода занимает меньше времени.

 

1.4.5 Выбор СУБД для Web сервера

В качестве сервера баз данных был использован MS SQL Server 2000. Первоначально предполагалось использование MS Access, но Access настольная (одна программа на один компьютер) система управления данными, а SQL Server одна из мощнейших сетевых СУБД с возможностью параллельной работы множества пользователей. Высокая скорость обработки, выборки, изменения данных посредством SQL запросов ставит SQL сервер выше всех конкурентов. Конкуренцию может составить Oracle, но данная СУБД предназначена для решения более глобальных задач. В моём случае данных относительно мало. Такое количество данных легко выдержит любая СУБД, но требуется высокая скорость обработки запросов и возможность работы в многопользовательском режиме. Версию я выбрал 2000, а не 2005 в связи с тем, что 2000 менее требовательна к ресурсам компьютера, а нововведения 2005 мне бы не пригодились. Описание СУБД MS SQL Server, благодаря которому можно понять всю мощь выбранной системы можно найти далее.

 

1.5 Описание средств разработки

В данном разделе я опишу все программные продукты, выбранные выше. Постараюсь выделить лишь самые значимые моменты для работы АИС и моменты, важные для разработки ПО.

1.5.1 «1С Предприятие». Конфигурация «Торговля и склад»

Программа "1С: Предприятие 7.7" , в частности продукт "1С: Торговля и склад", представляет собой недорогую, но надежную и достаточно функциональную систему, с помощью которой можнорешать большинство учетных задач, стоящих перед предприятием.

Программный продукт "1С: Торговля и склад 7.7" предназначен для учета любых видов торговых операций. Благодаря своей гибкости и возможности настройки, система «1С: Торговля и склад 7.7» способна выполнять все функции учета от ведения справочников и ввода первичных документов до получения различных ведомостей и аналитических отчетов.

Программа "1С: Торговля и склад 7.7" автоматизирует работу на всех этапах деятельности предприятия.

Я не считаю программирование в 1С высококвалифицированной работой. Трудность представляет полное понимание предметной области, грамотная постановка задачи, составление алгоритма и составление запросов на языке запросов 1С. Не случайно ведь есть много «программистов 1С», абсолютно не знающих основ баз данных, но решающих поставленные перед ними задачи. Такие «специалисты» являются очень узкоспециализированными.

"1С:Торговля и склад" содержит разнообразные средства для связи с другими программами.

Возможность импорта и экспорта информации через текстовые файлы позволит обмениваться данными практически с любой программой.

Кроме этого, встроенный язык содержит средства работы с файлами формата DBF.

Также "1С:Торговля и склад" поддерживает современные средства интеграции приложений: OLE, OLE Automation и DDE.

«1С» система обладает нужной гибкость и настраиваемостью. "1С:Торговля и склад" может быть адаптирована к любым особенностям учета на конкретном предприятии. В состав системы входит Конфигуратор, который позволяет при необходимости настроить все основные элементы системы:

  1. редактировать существующие и создавать новые необходимые документы любой структуры,
  2. изменять экранные и печатные формы документов,
  3. создавать журналы для работы с документами и произвольно перераспределять документы по журналам для эффективной работы с ними,
  4. редактировать существующие и создавать новые справочники произвольной структуры,
  5. редактировать свойства справочников: изменять состав реквизитов, количество уровней, тип кода, диапазон проверки уникальности кода и другое ,
  6. создавать регистры для учета средств в любых необходимых разрезах,
  7. создавать любые дополнительные отчеты и процедуры обработки информации,
  8. Похожие работы

< 1 2 3 4 5 6 > >>