АИС "Работа с покупателями"

ФункцияглВернутьЦену(Номенклатура,ТипЦены,ДатаЦены=0,ЦенаЦены=0,ЕдЦены=0,ВалЦены=0,НаценкаЦены=0,НайденнаяЦена=0,НеДобавИздержки=0)ЭкспортДалее ФункцияGlVozrOst(кд_ном)ЭкспортДалее ФункцияGlVozrCeni()ЭкспортДалее ФункцияGlVozrNom()ЭкспортДалее //############################################################################### //БлокдляработысинтернетмагазиномчерезWebслужбу //******************************************************************* //Функциявозвращаетпараметрпоимениизфайлаnastr.txtрабочегокаталога //Форматфайла: //строкиначинающиесяс#-коментарии //имяпараметразадаётсякак[имя],азначениележитнастрочкувнизу ФункцияПарамПоИмени(пар) ПеремномСтрок; Перемстр; Ткст=СоздатьОбъект("Текст"); Ткст.КодоваяСтраница(0); Ткст.Открыть(КаталогИБ()+"nastr.txt"); номСтрок=1; ПоканомСтрок<=Ткст.КоличествоСтрок()Цикл стр=Ткст.ПолучитьСтроку(номСтрок); //удаляемпробелывначалеиконцестроки СокрЛП(стр); ЕслистрДлина(стр)>0Тогда //Есликоментарий,топропускаем ЕслиЛев(стр,1)="#"Тогда номСтрок=номСтрок+1; Продолжить; КонецЕсли; //Есликакойтопараметр,тогда ЕслиЛев(стр,1)="["Тогда стр=лев(стр,стрДлина(стр)-1); стр=прав(стр,стрДлина(стр)-1); //Еслиэтотпараметр-искомый Еслистр=парТогда ВозвратСокрЛП(Ткст.ПолучитьСтроку(номСтрок+1)); КонецЕсли; КонецЕсли; КонецЕсли; номСтрок=номСтрок+1; КонецЦикла; Возврат"0";//Еслиничегоненашли-возвращаетноль КонецФункции //****************************************************************** //Функциявозвращаетколичествотоварапоегокоду,преднозначенадлявыводачерезWebслужбу ФункцияGlVozrOst(кд_ном)Экспорт ПеремОст; Ном=создатьОбъект("Справочник.Номенклатура"); Склд=СоздатьОбъект("Справочник.Склады"); Регр=СоздатьОбъект("Регистр.ОстаткиТМЦ"); Склд.НайтиПоКоду("00001"); Ном.НайтиПоКоду(кд_ном); Ост=0; Ост=Регр.СводныйОстаток(,ном.ТекущийЭлемент(),Склд.ТекущийЭлемент(),,"Количество"); ВозвратОст; КонецФункции //******************************************************************* //Функциявозвращаеттаблицузначений-номенклатурускодомиеёпараметры ФункцияGlVozrNom()Экспорт ПеремОст,ТабЗн; ПеремКатВыгр; Запрос=СоздатьОбъект("Запрос"); ТекстЗапроса= "//{{ЗАПРОС(Номенклатура) |Ном=Справочник.Номенклатура.ТекущийЭлемент; |ГруппировкаНом;"//}}ЗАПРОС ; ЕслиЗапрос.Выполнить(ТекстЗапроса)=0Тогда Предупреждение("Ошибкавзапросе"); КонецЕсли; КатВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Ном"); ДБФ=СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("EtoGruppa",1,1,0); ДБФ.ДобавитьПоле("KodNom",2,9,0); ДБФ.ДобавитьПоле("Otec",2,9,0); ДБФ.ДобавитьПоле("Strana",2,20,0); ДБФ.ДобавитьПоле("Naimenov",2,250,0); ДБФ.СоздатьФайл(КатВыгр+"nomen.dbf"); ДБФ.КодоваяСтраница(1); Запрос.ВНачалоВыборки(); ПокаЗапрос.Группировка(1)=1Цикл ДБФ.Добавить(); ДБФ.KodNom=Запрос.Ном.Код; ДБФ.Otec=Запрос.Ном.Родитель.Код; ДБФ.Strana=Запрос.Ном.СтранаПроисхождения.Наименование;; ДБФ.Naimenov=Запрос.Ном.Наименование; ДБФ.EtoGruppa=Запрос.ЭтоГруппа(1); ДБФ.Записать(); КонецЦикла; Возврат1; КонецФункции //******************************************************************* //Возвращаетценупоуказаннымпарметрам-используетсявзапросевнизу ФункцияВозрНомерПрайса(Кд)Экспорт ЕслиКд="00002"Тогда Возврат1; ИначеЕслиКд="00003"Тогда Возврат2; ИначеЕслиКд="00004"Тогда Возврат3; ИначеЕслиКд="00005"Тогда Возврат4; ИначеЕслиКд="00006"Тогда Возврат5; ИначеЕслиКд="00007"Тогда Возврат6; ИначеЕслиКд="00001"Тогда Возврат0; Иначе Возврат33;//Еслиошибка.0нельзя,т.к.вдругэтоунасболеенизкие КонецЕсли; КонецФункции //******************************************************************* //Функциявозвращаетценынаноменклатуруиномерпрайса ФункцияGlVozrCeni()Экспорт ПеремОст,ТабЗн; ПеремКатВыгр; ПеремизПроц; Запрос=СоздатьОбъект("Запрос"); ТекстЗапроса= "//{{ЗАПРОС(Цены) |Номенклатура=Справочник.Цены.Владелец; |ТипКод=Справочник.Цены.ТипЦен.Код; |Тип=Справочник.Цены.ТипЦен; |Цен=Справочник.Цены.ТекущийЭлемент; |ГруппировкаЦен; |"//}}ЗАПРОС ; ЕслиЗапрос.Выполнить(ТекстЗапроса)=0Тогда Предупреждение("Ошибкавзапросе"); КонецЕсли; КатВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Цен"); ДБФ=СоздатьОбъект("XBase"); ДБФ.ДобавитьПоле("Cena",1,8,2); ДБФ.ДобавитьПоле("Nomen",2,9,0); ДБФ.ДобавитьПоле("Prajs",1,2,0); ДБФ.СоздатьФайл(КатВыгр+"Ceni.dbf"); ДБФ.КодоваяСтраница(1); Запрос.ВНачалоВыборки(); ПокаЗапрос.Группировка(1)=1Цикл Если(Запрос.ТипКод<>"00010")Тогда ДБФ.Добавить(); глВернутьЦену(Запрос.Номенклатура,Запрос.Тип,,изПроц,,,,0); ДБФ.Cena=изПроц; ДБФ.Nomen=Запрос.Номенклатура.Код; ДБФ.Prajs=ВозрНомерПрайса(Запрос.ТипКод); ДБФ.Записать(); КонецЕсли; КонецЦикла; Возврат1; КонецФункции //******************************************************************* //Функциявозвращаетостаткиноменклатуры ФункцияGlVozrOstatki()Экспорт ПеремкатВыгр,дат; Перемск; ОСТ=СоздатьОбъект("XBase"); ОСТ.ДобавитьПоле("Kod",2,9,0); ОСТ.ДобавитьПоле("Ostatok",1,5,0); катВыгр=ПарамПоИмени("КаталогВыгр")+ПарамПоИмени("Ост"); ОСТ.СоздатьФайл(катВыгр+"ost.dbf");

АИС Работа с покупателями

Реферат

Компьютеры, программирование

Другие рефераты по предмету

Компьютеры, программирование

Сдать работу со 100% гаранией

РЕФЕРАТ

 

ВКР содержит пояснительную записку на 85 листах формата А4, включающую 21 рисунок, 11 таблиц, 24 литературных источника, 5 приложений.

WEB ПРОГРАММИРОВАНИЕ, WEB СЛУЖБА, 1С, C#, АВТОМАТИЗАЦИЯ, ADO, ТИРАЖИРОВАНИЕ, ИНСТРУКЦИЯ, COM.

Цель работы автоматизация работы с покупателями.

В процессе работы проведён анализ аппаратных и программных средств предприятия, выбраны технологии и средства для решения поставленных задач.

Результаты работы используются на предприятии. Программный комплекс выполняет следующие задачи:

  1. ускорение обслуживания покупателей на розничных торговых точках,
  2. ведение точного учёта товаров на удалённых точках,
  3. поддержка распределённой базы данных,
  4. предоставление полной информации по текущему ассортименту компании интерактивным пользователям Интернет портала,
  5. публикация новостей и данных о компании на Интернет портале,
  6. возможность оформления заказов через Интернет.

.СОДЕРЖАНИЕ:

ВВЕДЕНИЕ7

1 ПОСТАНОВКА ЗАДАЧИ НА ПРОЕКТИРОВАНИЕ8

1.1 Назначение и цели создания программного комплекса8

1.2 Что было до внедрения АИС.10

1.3 Структура компьютерной сети предприятия11

1.4 Выбор программных средств и технологий взаимодействия12

1.4.1 Выбор СУБД для автоматизации

хозяйственно-складской деятельности

и построения распределённой БД13

1.4.2 Выбор среды разработки14

1.4.3 Передача данных через локальную сеть15

1.4.4 Выбор языка программирования15

1.4.5 Выбор СУБД для Web сервера16

1.5 Описание средств разработки16

1.5.1 «1С Предприятие». Конфигурация «Торговля и склад»16

1.5.2 MS SQL Server 200021

1.5.3 MS Visual Studio.NET22

2 ФУНКЦИОНАЛЬНАЯ ЧАСТЬ25

2.1 Общее функционирование системы на базе «1С»25

2.2 Функции создания и поддержания распределённой БД26

2.3 Функции для переноса данных с сервера приложений 1С на WEB сервер (SQL Server)28

2.3.1 Функции WEB службы29

2.4 Функции ASP.NET приложения34

2.4.1 Схема работа Интернет сайта35

2.4.2 Функциональное назначение страниц37

3 ИНФОРМАЦИОННОЕ ОБЕСПЕЧЕНИЕ ПРИЛОЖЕНИЯ39

3.1 Общие принципы организации информационной базы39

3.2 Передача данных удалённым точкам39

3.3 Ведение БД на WEB сервере с использованием SQL Server 200039

4 ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ ПРИЛОЖЕНИЯ45

4.1 Программные средства для создания и поддержания распределённой БД45

4.1.1 Обработка на центральной базе «Выгрузка накладной»45

4.1.2 Обработка на удалённой торговой точке - «Загрузка документов»46

4.2 Автоматизация работы кассира в магазине48

4.3 WEB приложение50

4.3.1 Условия на работу WEB приложения у удалённого пользователя.51

4.3.2 Используемые средства52

4.3.2.1 Стандартные средства «WEB программирования»52

4.3.2.2 ASP.NET 2.052

4.3.2.3 ADO.NET53

4.3.3 Получение данных от WEB Службы53

4.3.4 Кэширование данных54

4.3.5 Отправка электронной почты55

4.3.6 Полномочия пользователей56

2.4.7 Проблемы и их решение57

5 ТЕХНОЛОГИЯ ЭКСПЛУАТАЦИИ ПРИЛОЖЕНИЯ59

5.1 Инструкция оператора системы 1С на удалённом магазине59

5.1.1 Общие сведения59

5.1.2 Порядок работы:59

5.1.3 Продажа (Реализация):60

5.1.4 Возврат продажи62

5.1.5 Использование меню фискального регистратора (ФР):64

5.1.6 Акт сверки:64

5.1.7 Печать ценников по подбору:66

5.1.8 Загрузка накладных:68

5.2 Эксплуатация WEB портала68

ЗАКЛЮЧЕНИЕ70

СПИСОК ИСПОЛЬЗОВАННЫХ ИСТОЧНИКОВ71

ПРИЛОЖЕНИЕ А КОНЦЕПТУАЛЬНВЯ МОДЕЛЬ ПЕРЕНОСА ДАННЫХ73

ПРИЛОЖЕНИЕ Б КОД WEB СЛУЖБЫ (ФАЙЛ «Service.asmx»)74

ПРИЛОЖЕНИЕ В ФУНКЦИИ ГЛОБАЛЬНОГО МОДУЛЯ, ФОРМИРУЮЩИЕ ДАННЫЕ ДЛЯ WEB СЛУЖБЫ 78

ПРИЛОЖЕНИЕ Г НЕКОТОРЫЕ ХРАНИМЫЕ ПРОЦЕДУРЫ И ЗАПРОСЫ К СИСТЕМЕ «SQL SERVER»82

ПРИЛОЖЕНИЕ Д КОД РАБОТЫ С WEB СЛУЖБОЙ ИЗ ASP.NET84

 

ВВЕДЕНИЕ

Каждая коммерческая организация старается вести точный и полный учёт своей деятельности. Не является исключением и компания, для которой разрабатывался данный комплекс программных средств.

Машины могут автоматизировать работу людей, лишь, будучи правильно запрограммированными.

Для ведения складского учёта используется программа 1С предприятие. Данная платформа была выбрана потому, что для её внедрения требуются относительно невысокие денежные и временные затраты. Кроме этого данная программа поддерживается производителями фискальных регистраторов (которые используются на точках розничной торговли) и постоянно обновляется в соответствии с изменением законодательства.

В данной области торговли существует жесткая конкуренция. Каждая компания пытается сделать покупку для своего покупателя максимально удобной, быстрой и приятной.

 

1 ПОСТАНОВКА ЗАДАЧИ НА ПРОЕКТИРОВАНИЕ

 

1.1 Назначение и цели создания программного комплекса

Назначение и цели создаваемого программного комплекса:

  1. автоматизация хозяйственно учётной деятельности предприятия посредством компьютеризации удалённых магазинов,
  2. автоматизация работы с покупателями на удалённых торговых точках,
  3. автоматизация работы с покупателями через Internet портал,
  4. предоставление информации о предприятии, его торговых точках и его ассортимента через Internet.

Задачи Интернет портала:

  1. Рассказать о предприятии широкому кругу заинтересованных лиц, дать полную информацию по центральному офису и торговым точкам (адреса, телефоны, время работы, схемы проезда),
  2. Дать покупателю возможность ознакомиться с ассортиментом и ценами компании в удобной форме,
  3. Дать менеджерам возможность публиковать новости, информируя покупателей (оптовиков),
  4. Обеспечить возможность заказа покупателем-оптовиком товара,
  5. Закачивание прайслиста по указанной группе товаров,
  6. Отправка текстового сообщения выбранному должностному лицу любым человеком через web интерфейс,
  7. Ведение статистики посещаемости.

Дополнительные требования, предъявленные руководителем предприятия:

  1. Ведение статистики по просмотру товаров (выяснить какие группы товаров интересуют WEB пользователей больше, а какие меньше),
  2. Каждый покупатель оптовик имеет свой пароль, свой прайс, свои полномочия,
  3. Неавторизированный покупатель видит товар, имеющийся на розничных точках, но не может просмотреть его количество. Цену для всех товаров отображать по первому прайсу (чем больше номер прайса, тем меньше его цена),
  4. Авторизированный пользователь видит лишь товар на оптовом складе. Также без конкретизации по количеству. Почему так рассказано далее,
  5. Прайс должен скачиваться в соответствии с полномочиями пользователя (два предыдущих пункта). Авторизированный пользователь, наделённый правами просмотра количества должен получить прайс с отражёнными остатками по всем имеющимся товарам,
  6. Не производить контроль количества запрашиваемого товара и его наличия. Если на остатке значится 10 позиций, а авторизированный пользователь пытается выписать 20, то не выводить ошибку «отсутствует нужное количество», а продолжить оформление заказа. Это сделано в связи с тем, что ассортимент большой и на складе (получатель сформированного заказа) оформят продажу 10 позиций, после чего свяжутся с покупателем, объяснят, что товара не хватает и предложат его аналоги, дабы он добрал до 20 штук. Такова политика предприятия, позволяющая таким образом поднять продажи.

 

 

1.2 Что было до внедрения АИС.

Локальная сеть с программой «1С», работающей в терминальном режиме. Менеджеры меняли цены, оптовый склад делал реализации покупателям. Товар на удалённые точки оформляется как перемещение на другой склад. Весь количественный учёт в магазинах вёлся на бумаге. Раз в несколько дней данные «документы» поступали в центральный офис, где работница забивала на компьютере документ «реализация», тем самым списывая товар с соответствующего склада. Практически каждый день менеджеры меняют цены на товар. После чего они по телефону(или по базе) узнавали есть ли данный товар в магазинах. Если есть, то они печатали ценники для магазинов. Работа эта кропотлива, в результате чего часто были ситуации, что цена на товар меняется, но магазины об этом не знают.

Теперь по работе с оптовыми покупателями. На каждый товар имеется несколько типов цен. Цена, по которой отпускается товар зависит от объёма либо текущего заказа, либо от того, сколько покупатель брал товара до этого. Получается каждому покупателю нужен свой прайс-лист. Причём именно по интересующей его группе товаров. Точное количество остатков на складе - коммерческая тайна. Но есть привилегированные покупатели, которым можно показать остатки. Много времени уходило на то, чтобы сформиро

Похожие работы

1 2 3 4 5 > >>