Автоматизированная информационная система "Справочная служба магазина"

АкторКраткое описание актораМенеджерОформление прихода и реализации товаров.ДиректорДиректор осуществляет общее руководство производственно-хозяйственной и финансово-экономической деятельностью предприятия, а так же организует взаимодействие

Автоматизированная информационная система Справочная служба магазина

Курсовой проект

Компьютеры, программирование

Другие курсовые по предмету

Компьютеры, программирование

Сдать работу со 100% гаранией

 

где Смр - стоимость ручных работ = 17000;

Смавт - оклад программиста, умноженный на коэффициент накладных расходов = 21019*1,3=27325;

 

Смавт = S( tотл+tввода+tреш+tкорр)*Смч*Кн = 15,5*50*3,4=2635 руб.

 

где Смч - стоимость 1 машинно-часа = 50;

Кн - коэффициент накладных расходов = 3,4.

Методика расчета трудоемкости ручного способа обработки информации

Оценка решения задачи на ЭВМ проводится в сравнении с ручным способом обработки информации.

Поэтому, прежде всего необходимо определить трудовые и стоимостные затраты ручного труда при обработке информации и с использованием ЭВМ.

Общая трудоемкость ручного способа обработки информации равна:

 

n

Тр=S ti*Кi / qi * К = 10*6/2*2,5=75 часов.

i=1

 

где ti - трудоемкость обработки группы документов вида I = 10;

Кi - годовое количество групп документов вида I = 6;- количество документов вида i в группе = 2;- количество наименований документов;

К - поправочный коэффициент для учета полной загрузки персонала, занятого обработкой информации = 2,5.

Общие стоимостные затраты ручного способа обработки информации

Общие стоимостные затраты ручного способа обработки информации (Ср) определяют по формуле:

 

Ср=Тр*Пчас*(1+Ксс+Кнр) = 75*400*(1+0,138+0,46)=30000*1,60=30001.60 руб.

 

где Пчас - тарифная среднегодовая ставка работников, занятых обработкой информации = 400;

Ксс - коэффициент, определяющий отчисления на социальные нужды = 0,138;

Кнр - коэффициент накладных расходов = 0,46.

Затраты времени на обработку информации по данной задаче

Затраты времени на обработку информации по данной задаче на ЭВМ складываются из времени на обработку выполнения ручных операций (Трм), машинноручных (Тмрм) и автоматических (Тавтм) операций:

 

Тм= Трм + Тмрм+ Тавтм = 75+20+15,5=110,5 часов

К ручным операциям относятся операции, выполняемые работниками - это постановка задачи, кодирование информации и т.д. Трудоемкость ручных операций определяется по изложенному выше порядку.

Расчёт экономической эффективности

Для определения экономической эффективности необходимо рассчитать следующие показатели: срок окупаемости (Ток) и расчетный коэффициент эффективности (Ер).

Показатель срока окупаемости показывает период времени (месяц, год), в течение которого дополнительные капитальные вложения окупятся за счет экономических затрат.

Коэффициент эффективности - это доля капитальных вложений на единицу текущих затрат.

Нормативный коэффициент эффективности (Ен) должен находиться в пределах от 0,15 до 2, а в срок окупаемости нормативный (Тн) находится в пределах от 0,6 до 1 года.

Срок окупаемости определяется по следующей формуле:

 

Ток=Кмод / Эмод = 350000/480000=0,7 года

 

где Кмод - капитальные вложения на устройства;

Эмод - годовая экономия от внедрения устройства.

Коэффициент эффективности капитальных вложений рассчитывается по формуле:

 

Ер=1/ Ток > 0,15 = 1/0.7=1,3

 

Годовая экономия от внедрения устройства рассчитывается по формуле:

 

Эгод =Эмод-Ен*Кмод = 480000-1,3*350000=25000 руб.

Вывод: исходя из данных расчетов, можно сделать вывод, что обработка информации с помощью данной информационной системы является эффективнее, нежели обработка вручную. Срок окупаемости системы около 0,7 года.

 

 

Заключение

 

При разработке программного продукта были поставлены задачи:

автоматизировать ввод и хранение информации о магазинах, товаре, покупателях;

автоматизировать процесс прихода и реализации товаров,

которые в процессе написания курсового проекта были реализованы.

 

 

Список литературы

 

1. Введение в конфигурацию 1С: Бухгалтерии 7. 7. -М., 2003 г.

. Компьютерная бухгалтерия 7.7.«Азбука бухгалтера». М., 2003г.

. Комягина В.Б. 1С: Бухгалтерия. М., 2004 г.

. Муштоватый И.Ф. Компьютер для бухгалтеров. Ростов-на-Дону, 2005 г

. Самоучитель 1С: Бухгалтерии версий 7.5-7.7 в вопросах и ответах. Практическое пособие- М.: Триумф,2002г.

. Фигурнов В. 1С: Бухгалтерия 7.7: Руководство пользователя. М.: Фирма 1С.

. Чистов Д. В. Основы бухгалтерского учета в системе Windows: Учеб.Практикум по ведению бухучета в 1С: Бухгалтерии 7.0.

. 1С: Бухгалтерия. Версия 7.7: Руководство пользователя. М.: Фирма 1С.

. 1С: Предприятие. Версия7.7.: Описание встроенного языка. М. : Фирма 1С.

. 1С: Бухгалтерия 7.7. Практический курс. М., 2004 г.

 

 

Приложения

 

Приложение 1

 

Листинг программы

Глобальный модуль

 

Функция глВзятьКонтекст(Конт) Экспорт

Возврат Конт;

КонецФункции // глВзятьКонтекст()

Процедура глПодбор(Конт,Параметры="") Экспорт

Если ТипЗначенияСтр(Параметры) <> "СписокЗначений" Тогда

Параметры = СоздатьОбъект("СписокЗначений");

КонецЕсли;

// открываем форму подбора

Конт.ОткрытьПодбор("Товар", "ДляПодбора", Параметры);

КонецПроцедуры // глПодбор()

Модуль формы списка справочника «Магазины»

//{{ПРОЦЕДУРА_ПЕЧАТИ(Печать)

Процедура Печать()

Спр = СоздатьОбъект("Справочник.Магазины");

Спр.ИспользоватьДату(ИспользоватьДату());

Таб = СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("Печать");

Таб.ВывестиСекцию("Шапка");

Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);

Спр.ВыбратьЭлементы();

Пока Спр.ПолучитьЭлемент() = 1 Цикл

Если Спр.ЭтоГруппа() = 1 Тогда

Таб.ВывестиСекцию("Группа");

Иначе

Таб.ВывестиСекцию("Строка");

КонецЕсли;

КонецЦикла;

Таб.ВывестиСекцию("Подвал");

Таб.ТолькоПросмотр(1);

Таб.Показать("Печать Магазины","");

КонецПроцедуры

//}}ПРОЦЕДУРА_ПЕЧАТИ

Модуль формы списка справочника «Товар»

//{{ПРОЦЕДУРА_ПЕЧАТИ(Печать)

Процедура Печать()

Спр = СоздатьОбъект("Справочник.Товар");

Спр.ИспользоватьДату(ИспользоватьДату());

Таб = СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("Печать");

Таб.ВывестиСекцию("Шапка");

Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);

Спр.ВыбратьЭлементы();

Пока Спр.ПолучитьЭлемент() = 1 Цикл

Если Спр.ЭтоГруппа() = 1 Тогда

Таб.ВывестиСекцию("Группа");

Иначе

Таб.ВывестиСекцию("Строка");

КонецЕсли;

КонецЦикла;

Таб.ВывестиСекцию("Подвал");

Таб.ТолькоПросмотр(1);

Таб.Показать("Печать Товар","");

КонецПроцедуры

//}}ПРОЦЕДУРА_ПЕЧАТИ

Модуль формы списка «ДляПодбора» справочника «Товар»

Процедура Остатки()

Параметр = глВзятьКонтекст(Контекст);

ОткрытьФорму("Обработка.ПоказатьОстатки", Параметр);

ФормаТаблицыОстатков = Параметр; // через параметр возвращается контекст открытой формы обработки

КонецПроцедуры // Остатки()

Модуль документа «Приход»

Процедура ОбработкаПроведения()

ВыбратьСтроки();

Пока ПолучитьСтроку()=1 Цикл

Регистр.ОстаткиТоваров.Товар=Товар;

Регистр.ОстаткиТоваров.Магазин=Магазин;

Регистр.ОстаткиТоваров.Количество=Количество;

Регистр.ОстаткиТоваров.ДвижениеПриходВыполнить();

КонецЦикла;

КонецПроцедуры

Модуль формы документа «Расход»

Процедура Подбор()

Параметры = СоздатьОбъект("СписокЗначений");

Параметры.ДобавитьЗначение(Магазин, "Магазин");

Если Выбран() = 0 Тогда

Параметры.ДобавитьЗначение("Дата", "ТипГраницы");

Параметры.ДобавитьЗначение(ДатаДок, "ЗначениеГраницы");

Иначе

Параметры.ДобавитьЗначение("Позиция", "ТипГраницы");

Параметры.ДобавитьЗначение(ПолучитьПозицию(), "ЗначениеГраницы");

КонецЕсли;

Параметры.ДобавитьЗначение("Подбор номенклатуры в документ " + ПредставлениеВида() + " № " + НомерДок, "Заголовок");

глПодбор(Контекст, Параметры);

КонецПроцедуры // Подбор()

Процедура ОбработкаПодбора(ВыбрТов, Конт)

Кол = 1;

ЦенаТ=0;

Если ВвестиЧисло(Кол, "Введите количество товара", 14, 0) = 0 Тогда

Возврат;

ИначеЕсли Кол = 0 Тогда

Возврат;

КонецЕсли;

НоваяСтрока();

Товар = ВыбрТов;

Количество = Кол;

АктивизироватьСтроку();

КонецПроцедуры

Модуль документа «Расход»

Процедура ОбработкаПроведения()

ВыбратьСтроки();

Пока ПолучитьСтроку()=1 Цикл

Регистр.ОстаткиТоваров.Товар=Товар;

Регистр.ОстаткиТоваров.Магазин=Магазин;

Регистр.ОстаткиТоваров.Количество=Количество;

Регистр.ОстаткиТоваров.ДвижениеРасходВыполнить();

КонецЦикла;

КонецПроцедуры

Модуль формы отчета «ОстаткиТоваров»

Процедура Сформировать()

Перем Запрос, ТекстЗапроса, Таб;

//Создание объекта типа Запрос

Запрос = СоздатьОбъект("Запрос");

ТекстЗапроса =

"//{{ЗАПРОС(Сформировать)

Похожие работы

<< < 1 2 3 4 >