Автоматизация учета материалов на складе в среде "1C:Предприятие" в соответствии с особенностями финансовой деятельности предприятия

1СтудентуИванову Ивану Ивановичу2Тема работыКонфигурирование бухгалтерской информационной системы 1С Предприятие в соответствии с особенностями финансовой деятельности фирмы ООО Город3Срок сдачи студентом

Автоматизация учета материалов на складе в среде 1C:Предприятие в соответствии с особенностями финансовой деятельности предприятия

Дипломная работа

Компьютеры, программирование

Другие дипломы по предмету

Компьютеры, программирование

Сдать работу со 100% гаранией
О «Город».

 

Список литературы

 

1.1С: Бухгалтерия 7.7. Практическое руководство. Быстрый старт, Михайлов Н. В., Изд.: "Триумф", 2008г.

.1С: Бухгалтерия 7.7. Ведение бухгалтерского учета, Кульбицкий С. А., Изд.: "Триумф", 2009г.

.1C: Предприятие. Комплексная конфигурация. Секреты работы, Д. Рязанцев, Н. Рязанцева, Изд.: БХВ-Петербург, 2006 г.

.1С: Предприятие. Практика программирования на платформе V7, Колпинский Н. Н., Изд.: ИКС Технологии, 2007г.

.1С: Предприятие: программирование для всех, О. В. Бартеньев, Изд.: Диалог-МИФИ, 2007г.

.1С: Предприятие. Эффективное программирование, Т. Н. Усиков, Изд.: Новое знание, 2008г.

.1С: Предприятие 7.7: практический самоучитель., Филимонова Е. В., Изд.: "Феникс", 2008г.

.Азбука программирования в 1С Предприятие 7.7, БХВ-Петербург, 2008 г.

.Бухгалтерский учет: Учебное пособие. Кондраков Н.П. Инфра-М, 2009г.

.Бухгалтерский учет. В.М. Богаченко, Н.А. Кириллова. Феникс, 2008г.

.Новейший самоучитель по 1С: Бухгалтерия 7.7, Кузнецов В., Изд.: БХВ-Петербург, 2008г

."Практическая работа в 1С: Бухгалтерии 7.7", Лаптев В. В., Митченко И. А., Щербакова М. В., Изд.: "1С-Паблишинг", 2009г.

.Самоучитель 1С: Бухгалтерия 7.7, Д. Рязанцев, Н. Рязанцева, Изд.: БХВ-Петербург, 2008 г.

.Устав предприятия ООО «Город»

.Официальный сайт фирмы 1С. http://www.1c.ru/

.Сайт сети 1С Бухучет и торговля www.1cbit.ru

Приложение 1.

 

Листинг кода модуля Остатки материалов на складах.

//************************************************

Процедура ПриОткрытии ( ) Склад=Константа.ОсновнойСклад; )

Конец процедуры

//************************************************

Процедура Очистить()

ВыбСклад="" ;

Конец процедуры

//************************************************

Процедура Сформировать()

ОбщСуммаР=О;

Если ПустоеЗначение(ВыбСклад)=l Тогда

ТекСклад="все склады";

Иначе

ТекСклад=ВыбСклад;

КонецЕсли;

Спр=СоздатьОбъект ("Справочник. Материалы");

РегОст = СоздатьОбъект("Регистр.ОстаткиМатериалов");

Таб=СоздатьОбъект ("Таблица") ; Таб.ИсходнаяТаблица ("Таблица") ;

ТабЗн=СоздатьОбъект("ТаблицаЗначений"); ТабЗн.НоваяКолонка("Материал");

ТабЗн. НоваяКолонка"( "Код") ; ТаБЗн. НоваяКолонка ("Остаток") ;

ТабЗн.НоваяКолонка("ЦенаРозничная"); ТаБЗн.НоваяКолонка("Документ");

ТабЗн. НоваяКолонка ("Дата") ; Таб. ВывестиСекцию ( "Шапка") ;

Спр.ВыбратьЭлементы();

Пока Спр. Получить Элемент ( ) = 1 Цикл

Если Спр.ЭтоГруппа()=l Тогда

Продолжить; КонецЕсли;

Если Спр.ПометкаУдаления()=l Тогда

Продолжить;

КонецЕсли ; ТаБЗн.НоваяСтрока();

ТабЗн. материал=Спр. Наименование; ТабЗн. Код=Спр. Код;

Если Пустое3начение(Вы6Склад)=1 Тогда

ТабЗн.остаток=Регост.Сводныйостаток(,Спр.текущийЭлемент()"

,остатокМатериала ") ;

Иначе

ТабЗН. Остаток=РегОст. СводныйОстаток (, Спр. ТекущийЭлемент () , ВыбСклад, "остаток )материала) ;

КонецЕсли ;

ТабЗн.ЦенаРозничная=Спр.РозничнаяЦена.Получить(РабочаяДата());

КонецЦикла;

ТабЗн. Свернуть ("Материал, Код, Остаток",, ЦенаРозничная") ;

ТабЗн . Сортировать (" 1 +") ;

ТабЗн. Вы6ратьСтроки () ;

Пока Таб3н. Получить Строку () =1 Цикл

Если ВыводитьНулевыеОстатки=О Тогда

Если Та63н.Остаток<=О Тогда

Продолжить;

КонецЕсли;

КонецЕсли;

Материал=ТабЗн. Материал;

Код=Таб3н. Код;

Остаток=Таб3н. Остаток; ЦенаРозничная=Таб3н.ЦенаРозничная; ОбщаяСуммаР=ОбщСуммаР+Остаток*ЦенаРозничная;

Таб. ВывестиСекцию ( "Строка") ; КонецЦикла;

Таб. ВывестиСекцию ("Итог") ;

Таб.Опции(О,О,О,О); Таб.Показать();

КонецПроцедуры

//***************************************************

 

Приложение 2.

 

Листинг кода модуля Продажа излишков материалов со склада

//*****************************

Процедура ПриОткрытии()

НачДата=НачМесяца (РабочаяДата (} ) КонДата=РабочаяДата ( ) ; Подокументно=1 ; КонецПроцедуры

//******************************

Процедура Очистить ( ) ВыбКонтрагент=" " ; КонецПроцедуры

Процедура Сформировать ( ) ОбщСумма=0 ;

Если ПустоеЗначение (ВыбКонтрагент) =1 Тогда ПоКонтрагенту="по всем контрагентам"

Иначе

ПоКонтрагенту=ВыбКонтрагент;

КонецЕсли;

Док=СоздатьОбъект( "Документ") ; Таб=Создать Объект ("Таблица");

Если Подокументно=1 Тогда

Таб . ИсходнаяТаблица ( "Таблица" ) ; Иначе

Таб . ИсходнаяТаблица ("БезДокументов") ; КонецЕсли;

ТабЗн=Создать Объект ("ТаблицаЗначений") ;

ТабЗн . НоваяКолонка ( "Материал" ) ;

ТабЗн . НоваяКолонка ( "Код" ) ;

ТабЗн . НоваяКолонка ( "Кво" ) ;

ТабЗн . НоваяКолонка ( " ЦенаСНДС " ) ;

ТабЗн . НоваяКолонка ( "СуммаСНДС" ) ;

ТабЗн . НоваяКолонка ( "Документ" ) ;

Таб. ВывестиСекцию ( "Шапка") ;

Док.ВыбратьДокументы(НачДата, КонДата);

Пока Док.ПолучитьДокумент()=1 Цикл

Если Док.Вид()"РасходнаяНакладная" Тогда Продолжить;

КонецЕсли;

Если Док.Проведен()=0 Тогда

Продолжить; КонецЕсли;

Если Док.ПометкаУдаления()=1 Тогда

Продолжить; КонецЕсли;

Если ПустоеЗначение(ВыбКонтрагент)<>1 Тогда

Если Док.Контрагентовыбконтрагент Тогда

Продолжить; КонецЕсли;

КонецЕсли;

Док.ВыбратьСтроки();

Пока Док.ПолучитьСтроку()=1 Цикл

ТабЗн.НоваяСтрока();

ТабЗн.Материал=Док.Материал.Наименование;

ТабЗн.Код=Док.Товар.Код;

ТабЗн.Кво=Док. Кво;

ТабЗн.ЦенаСНДС=Док.ЦенаСНДС;

ТабЗн.СуммаСНДС=Док.СуммаСНДС;

Если Подокументно=1 Тогда

ТабЗн.Документ=Док.ТекущийДокумент();

КонецЕсли; КонецЦикла; КонецЦикла;

Если Подокументно=1 Тогда

ТабЗн.Свернуть("Материал,Код,ЦенаСНДС,Документ","Кво,СуммаСНДС"); Иначе

ТабЗн.Свернуть("материал,Код","Кво,ЦенаСНДС,СуммаСНДС"); КонецЕсли;

ТабЗн.Сортировать("1+");

ТабЗн.Выбрать Строки();

Пока ТабЗн.ПолучитьСтроку()=1 Цикл

Товар=ТабЗн.Материал;

Код=ТабЗн.Код;

Кво=ТабЗн.Кво;

Если Подокументно=1 Тогда

Документ=ТабЗн.Документ; ДатаДокумента=Документ.ДатаДок; Цена=ТабЗн.ЦенаСНДС;

Иначе

Цена=ТабЗн.СуммаСНДС/Кво;

КонецЕсли;

Сумма=ТабЗн.СуммаСНДС;

ОбщСумма=ОбщСумма+Сумма;

Таб.ВывестиСекцию("Строка"); КонецЦикла;

Таб.ВывестиСекцию("Итог"); Таб.Опции(О,О,О,0); Таб.Показать();

Конец Процедуры

Похожие работы

<< < 4 5 6 7 8