"1С-Предприятие" и другие компьютерные системы учета и управления

Дипломная работа - Компьютеры, программирование

Другие дипломы по предмету Компьютеры, программирование

Скачать Бесплатно!
Для того чтобы скачать эту работу.
1. Пожалуйста введите слова с картинки:

2. И нажмите на эту кнопку.
закрыть



. Если в процедуре не используется оператор Возврат, то его неявное выполнение происходит вслед за последним исполняемым оператором процедуры. Данный оператор может применяться только в теле описания процедуры или функции, причем может задаваться только в случае использования оператора в контексте функции.

Символы

 

СимволЗначение[ ]В квадратных скобках заключаются необязательные синтаксические элементы.( )Круглые скобки заключают в себе список параметров.|Вертикальной линией разделяются синтаксические элементы, среди которых нужно выбрать только один.

Специальные символы, используемые в исходном тексте

//Двумя знаками косая черта начинается комментарий. Комментарием считается весь текст от знака "//" до конца текущей строки.|Вертикальная черта в начале строки используется только в строковых константах и означает, что данная строка является продолжением предыдущей (перенос строки), (см. Строковые константы).~Знаком тильда начинается метка оператора.:Двоеточием заканчивается метка оператора.;Точка с запятой является символом разделения операторов.( )В круглые скобки заключается список параметров методов, процедур и функций.[ ]В квадратные скобки заключается размерность массивов., Запятая разделяет параметры в списке параметров методов, процедур и функций." "В двойные кавычки заключаются строковые константы. В одинарные кавычки заключаются константы даты..Десятичная точка в числовых константах. Разделитель, используемый в описаниях агрегатных типов данных.+Символ плюс обозначает операцию сложения.-Символ минус обозначает операцию вычитания.*Символ звездочка обозначает операцию умножения./Символ косая черта обозначает операцию деления.>Правая угловая скобка обозначает логическую операцию больше.>=Логическая операция больше или равно.Две угловые скобки обозначают логическую операцию не равно.

Пример

Рассмотрим часть модуля документа Счет в программе 1С: Бухгалтерия

 

Процедура Печать - создание печатной формы документа.

 

Процедура Печать()

Таб = Создать Объект ("Таблица");

ИмяФайлаПечатнойФормы = КаталогИБ()+"ExtForms\PrnForms\1cbs.mxl";

Если ФС.СуществуетФайл(ИмяФайлаПечатнойФормы) = 1 Тогда

Таб.ИсходнаяТаблица(ИмяФайлаПечатнойФормы);

Иначе

Таб.ИсходнаяТаблица("Таблица");

КонецЕсли;

Таб.ВывестиСекцию("Шапка");

 

ВыбратьСтроки();

Ном = 0;

Пока ПолучитьСтроку()=1 Цикл

Ном = Ном + 1;

Таб.ВывестиСекцию("Строка");

КонецЦикла;

 

Таб.ВывестиСекцию("Итого");

Таб.ВывестиСекцию("НДС");

Если УчитыватьНП = 1 Тогда

Таб.ВывестиСекцию("НП");

КонецЕсли;

Таб.ВывестиСекцию("Подвал");

 

КонецПроцедуры

Процедура Ввод на основании - документ будет выводиться на основании другого документа.

Процедура ВводНаОсновании(ДокОсн) //предопределенная

Новый = 1;

Если ДокОсн.Вид() = "РасходнаяНакладная" Тогда

РасчетныйСчет = ДокОсн.РасчетныйСчет;

Контрагент = ДокОсн.Контрагент;

Договор = ДокОсн.Договор;

Плательщик = ДокОсн.Контрагент;

ВариантРасчетаНалогов = ДокОсн.ВариантРасчетаНалогов;

ДокОсн.ВыбратьСтроки();

Пока ДокОсн.ПолучитьСтроку() = 1 Цикл

НоваяСтрока();

Товар = ДокОсн.Товар;

Количество = ДокОсн.Количество;

Цена = ДокОсн.Цена;

Сумма = ДокОсн.Сумма;

НДС = ДокОсн.НДС;

НП = ДокОсн.НП;

Всего = ДокОсн.Всего;

КонецЦикла;

КонецЕсли;

КонецПроцедуры //ВводНаОсновании

 

Средства администрирования

Основные средства администрирования системы 1С:Предприятие реализованы в составе конфигуратора. Однако есть ряд механизмов и утилит, которые не входят в состав конфигуратора, хотя также имеют отношение к администрированию системы 1С:Предприятие. Перечислим наиболее важные механизмы и инструменты, входящие в состав средств администрирования:

25 Аутентификация

 

Механизм аутентификации позволяет определить, кто именно из пользователей, перечисленных в списке пользователей системы, подключается к прикладному решению в данный момент.

Система поддерживает два вида аутентификации, которые могут использоваться в зависимости от конкретных задач, стоящих перед администратором информационной базы:

аутентификация средствами 1С:Предприятия;

аутентификация средствами Windows.

 

25.1 Аутентификация средствами 1С:Предприятия

 

 

Для выполнения аутентификации средствами 1С:Предприятия пользователь, при начале работы с прикладным решением, должен выбрать (или ввести) имя пользователя и соответствующий этому имени пароль:

 

Если пароль, введенный пользователем, не соответствует тому, который хранится в информационной базе, доступ к прикладному решению будет закрыт:

 

 

25.2 Аутентификация средствами Windows

 

 

При выполнении аутентификации средствами Windows, от пользователя не требуется каких-либо действий по вводу логина и пароля. Система анализирует, от имени какого Windows-пользователя выполняется подключение к прикладному решению, и на основании этого определяет соответствую

s