"1С-Предприятие" и другие компьютерные системы учета и управления

Дипломная работа - Компьютеры, программирование

Другие дипломы по предмету Компьютеры, программирование

Скачать Бесплатно!
Для того чтобы скачать эту работу.
1. Пожалуйста введите слова с картинки:

2. И нажмите на эту кнопку.
закрыть



звращаемое Значение в выражение, в котором используется функция. Использование данного ключевого слова в функции обязательно.Выражение, значение которого содержит результат обращения к функции.КонецФункцииОбязательное ключевое слово, обозначающее конец исходного текста функции.

Описание

Ключевое слово Функция начинает секцию исходного текста функции, выполнение которой можно инициировать из любой точки программного модуля, просто указав Имя_функции со списком параметров (если параметры не передаются, то круглые скобки, тем не менее, обязательны). Если в глобальном программном модуле в теле описания функции использовано ключевое слово Экспорт, то это означает, что данная функция является доступной из всех других программных модулей конфигурации. Ключевое слово Экспорт имеет смысл использовать только в глобальном программном модуле.

Выполнение функции заканчивается обязательным оператором Возврат. Функции отличаются от процедур только тем, что возвращают Возвращаемое Значение. Конец программной секции функции определяется по оператору КонецФункции.

Вызов любой функции в тексте программного модуля можно записывать как вызов процедуры, т. е. в языке допускается не принимать от функции возвращаемое значение.

Переменные, объявленные в теле функции в разделе Объявления_локальных_переменных, являются локальными переменными данной функции, поэтому доступны только в этой функции (за исключением случая передачи их как параметров при вызове других процедур, функций или методов).

Управляющие операторы

Если

Оператор условного выполнения.

Синтаксис:

Если Тогда

//операторы;

[ИначеЕсли Тогда]

//операторы;

[Иначе]

//операторы;

КонецЕсли;

 

Логическое выражение.ТогдаОператоры следующие за Тогда выполняются, если результатом логического выражения в конструкции Если является истина.//операторыИсполняемый оператор или последовательность таких операторов.ИначеЕслиЛогическое выражение, следующее за ключевым словом ИначеЕсли вычисляется только тогда, когда условия в Если и всех предшествующих ИначеЕсли оказались ложными. Операторы следующие за конструкцией ИначеЕсли Тогда выполняются, если результатом логического выражения в данном ИначеЕсли является истина.ИначеОператоры, следующие за ключевым словом Иначе выполняются, если результаты логических выражений в конструкции Если и всех предшествующих конструкциях ИначеЕсли оказались ложными.КонецЕслиКлючевое слово, которое завершает структуру оператора условного выполнения.

Описание:

Оператор Если управляет выполнением программы, основываясь на результате одного или более логических выражений. Оператор может содержать любое количество групп операторов, возглавляемых конструкциями

ИначеЕсли Тогда.

Пока

Оператор выполнения цикла.

Синтаксис:

Пока Цикл

//операторы;

КонецЦикла;

Параметры:

 

Логическое выражение.ЦиклОператоры, следующие за ключевым словом Цикл, выполняются, пока результатом логического выражения является истина.//операторы;Исполняемый оператор или последовательность таких операторов.КонецЦиклаКлючевое слово, которое завершает структуру оператора цикла.

Описание:

Оператор цикла Пока предназначен для циклического повторения операторов, находящиеся внутри конструкции Цикл ... КонецЦикла. Цикл выполняется пока логическое выражение истина. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Для

Оператор выполнения цикла.

Синтаксис:

Для Цикл

//Операторы;

КонецЦикла;

Параметры:

 

.//ОператорыИсполняемый оператор или последовательность таких операторов.КонецЦиклаКлючевое слово, которое завершает структуру оператора цикла.Описание

Оператор цикла Для предназначен для циклического повторения операторов, находящиеся внутри конструкции Цикл ... КонецЦикла. Перед началом выполнения цикла значение . Величина приращения счетчика при каждом выполнении цикла равна 1. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Попытка

Обработка исключительных ситуаций.

Синтаксис:

Попытка

// Некоторые действия;

Исключение

// Обработка исключительной ситуации;

КонецПопытки;

Параметры:

// Некоторы

s